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FC-GE series Camera  
Software Installation Manual 

 

 

 
 

GigE Vision Camera 
 
 
 
●  This manual describes mainly a way to connect the FC-GE series camera (FC1250GE/FC1650GE/FC2200GE/ 

FC5200GE /FC11000GE etc.) to PC and to capture images after installing software. 
Please refer to “CCD Video Camera Instruction Manual” of separate volume for information about handling  
method of camera main unit. 
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Introduction 
 
FC-GE series camera is a Gigabit Ethernet-based camera complying with GigE Vision standard. 
 

・GigE Vision 
GigE Vision is a camera interface standard for transmitting video data over Gigabit Ethernet networks that was 
initiated mainly by a group of AIA (Automated Imaging Association) members. GigE Vision enables vast quantities of 
image data to be transmitted using low cost standard LAN cables. Also, It enables the high-speed transmission of 
uncompressed image data over long distance up to 100m without repeater. 
 
For your reference, more detailed GigE Vision information can be found on the website of “AIA”.             
http://www.machinevisiononline.org/ 
 
・iPORT GigE IP engine 
FC-GE series camera is equipped with iPORT which is the GigE Vision-compliant IP protocol engine by Pleora 
Technologies Inc.(Canada), on the image data transmission interface part. The development of custom applications 
can be made using this software development kit (SDK) for iPORT. 
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※※※※    Ethernet® is a registered trademark of Xerox Corporation USA. 
※※※※    iPORT® is a registered trademark of Pleora Technologies CANADA. 
 
(Note) This instruction manual offers explanations through the contents of SDK ”eBUS SDK 

2.0.1.1951”, ”eBUS-Vision Package 4.0.1.1951”. 
(Note) Existing “eBUS-PureGEV SDK” is abbreviated to “eBUS SDK” in “eBUS-PureGEV Package 2.0.1 or later  

version”. SDK in provided CD-ROM is “eBUS SDK”,” eBUS-Vision Package”(in CD-ROM version 2.0 or later). 
 
<SDK in provided CD-ROM> 
“eBUS_SDK_2.0.1.1951”(Equivalent to existing “eBUS-PureGEV Package”) 
“eBUS-Vision_Package_4.0.1.1951” 
 

1.Usage environment 
 

Please confirm the usage environment of the hardware and software before using FC-GE series camera. 
 
(1-1) Camera, power source and camera cable 

Refer to the “CCD Video Camera Instruction Manual” of separate volume 
 

(1-2) PC (Computer) 
It is recommended to use the device of higher grade spec as follows especially when connecting with the camera 
of over one million pixels. 
・OS:  Microsoft Windows XP (32bit version)(SP2 or later ※※※※Recommended SP3 or later ) or Vista (32bit version) 

Microsoft Windows 7 (32bit/64bit version)  (Pre-Windows2000 OS is not operable.) 
・PC:  CPU Core2 Duo 2.4GHz or greater 
・Main memory:  2GB or more 
・Video card:  Graphic memory 256MB DDR2 or more / Interface: PCI Express bus ×16 or more(Indispensable when  

image display processing is required.) 
(Note) It may not normally display images when an on-board graphic function incorporated in a normal 

motherboard is used. 
 

(1-3) LAN card (NIC) 
Use a Pro/1000 LAN card (NIC) by Intel or a LAN card equipped with compatible chipset (List below) to capture 
images output from the camera at a fast rate. 
Use a motherboard equipped with a chipset (List below) compatible with Pro/1000 LAN card (NIC) by Intel when 
using LAN I/F function embedded in motherboard.  
 
Recommended LAN card: Intel PRO/1000GT desktop・adaptor/ Model:PWLA8391GT(1ch , PCI bus ) 

Intel PRO/1000MT desktop・adaptor/ Model:PWLA8492MT(2ch , PCI bus ) 
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[List of Compatible chipset] 
82540 EM - 100E,  82540 EM - 1015,  82540 EP - 1016,  82540 EP - 101E，82541 EI - 1013，  82541 EI - 1018，  82541 ER - 1014， 

 82541 ER - 1078， 82541 GI  - 1076，82541 GI - 1077， 82541 PI - 107C， 82545 EM - 100F，82545 EM - 1011，82545 GM - 1026， 
 82545 GM - 1027，82545 GM -1028,  82546 EB - 1010，82546 EB - 1012， 82546 EB - 101D，82546 EB - 1079，82546 EB - 107A， 
 82546 EB - 107B，82546 EB - 108A，82546 GT - 1099，82546 GT - 10B5，82547 EI - 1019，   82547 EI  - 101A，82547 GI - 1075， 
 82571 EB - 105E，82571 EB - 105F，82571 EB - 1060，82571 GB - 10A4，82572 E  - 108B，  82572 E  - 108C， 82572 EI - 107D， 
 82572 EI  - 107E， 82572 EI  - 107F，82572 EI  - 10B9，82573  L - 109A 

 
(1-4) eBUS driver and iPORT SDK (software development kit)  

It is included in the attached CD. 
Pleora/ eBUS-Vision Package    （eBUS-Vision_Package_4.0.1.1951.exe ） 
Pleora/ eBUS SDK              （eBUS_SDK_2.0.1.1951.exe） 

(Note) The version of attached SDK Is subject to change by version upgrade. 
 

(1-5) FCTool (Ver.1.00 or later version)   
It is included in the attached CD or is capable to download from our website. 
TAKENAKA SYSTEM / FCTool (Ver.1.00)  (FCTool_V100.zip)  
Serial communication control software exclusively for TAKENAKA’s FC camera. 
 

(Note) It is unnecessary if only a parameter setting by GenICam API is done using third-party image processing 
software complying with development environment of eBUS SDK(existing “eBUS-PureGEV Package”) and 
GenICam standard. 

  
(1-6) Null-modem emulator 

It is included in the attached CD. 
This is the software to unify the image capture evaluation software “Coyote” and the communication software for 
external serial control (FC Tool etc.) via virtual port when controlling this series of camera by serial 
communication command. 
The attached CD includes Null-modem emulator software”com0com” which is GPL license software (kind of free 
software). 
Refer to “License Agreement” displayed when installing the software about usage and redistribution of it. 
  
sourceforge.net/ com0com Null-modem emulator (com0com-2.1.0.0-i386-chk.zip) 
 
 More detailed information about ‘com0com”“ can be found on the website below. 
 http://sourceforge.net/projects/com0com/ 
 

(Note) It is unnecessary if only a parameter setting by GenICam API is done. 
(Note) The source file of this software is all open to the public and is available online from the above website. 
Please contact us If you cannot get the source file on the grounds that you have not device necessary for access 
to the Internet, and we will send it to you by mail afterward. 

※Let us humbly say that the shipping cost will be billed at cost. 
(Note) It is obliged to attach the source file or to provide the means for accessing when redistributing this software. 
Please refer to the website above for more information. 
 
Besides the above-cited softwares, the null-modem emulator introduced in the following website is also usable 
as described in the “Software Guide” of attached Coyote. Note that the “Virtual Serial Port Kit” is not charge-free.      
http://www.virtual-serial-port.com/   (Virtual Serial Port Kit) 

 
(1-7) Internet connection environment 

It might be necessary to download a packaged software of upgrade OS (Windows XP, SP3 etc.) or a software 
tool via Internet-connected computer to install or operate the software attached to the product, depending on the 
computer environment. This computer will not necessarily be the same as that connected to the camera. 
Please contact us If you cannot access to the internet and need to download these softwares. 
 
 
 
 
 
 
 
 
 
 
 
 

[Important] Selection of SDK in the development of application software 
This product adopts the iPORT by Pleora,CANADA as an IP engine. 
iPORT has “eBUS-PureGEV Package”(GenICam API-compliant development environment / Equivalent of existing “eBUS-PureGEV Package”) 
and ” eBUS-Vision Package”(non-GenICam API-compliant) as SDK. 
 
“eBUS-Vision Package” including the demonstration display software “Coyote” has been used for many years as iPORT development 
environment. However Pleora is now strongly recommending “eBUS SDK”(GenICam API-compliant development environment) as a 
development environment of new supplication software, because GenICam API-compliant camera products by GigE camera makers or 
third-party image processing software makers are now becoming more common.  
 
We recommend to use the GenICam API-compliant development environment “eBUS SDK” to newly develop user application softwares unless 
there is some special reason where the iPORT interface or the application software for GigE camera has been developed on the platform of 
“eBUS-Vision Package” by Pleora.  
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2.Installation of LAN card and setting of Operating software 
 

To newly plug a LAN card into a PC, perform the following steps. 
This is a Windows 7-based description. 

 
(2-1) Setting up of the LAN card and installation of the device driver software 

①Fit the LAN card (intel PRO/1000GT etc.) to the internal bus socket with the power supply disconnected and 
the AC cord pulled out. 

②A new LAN card is automatically detected and a device driver software is automatically installed when PC is 
powered up. 
 

・In the case that the driver software is not automatically installed in incorporating intel PRO/1000GT desktop・adapter. 
In the case that the driver software is not automatically installed in incorporating  
TAKENAKA recommended LAN card ”intel PRO/1000GT desktop・adapter”, install the    
driver software using the driver disk attached to the LAN card or download the “Windows  
2000,XP,and Server 2003”-compatible (in case of XP,Windows7) driver software after  
accessing the URL below and searching suitable “Software” (PRO2KXP_v13_5.exe etc.)  
by the keyword of ”PRO/1000 GT Desktop Adapter”. 
http://www.intel.com/  (Top page of Intel)  
 
(Note) It can not be detected by the “hardware updating wizard” as it is exe format   
(executable file format). When the updating wizard starts, cancel and stop it, then  
double-click on said downloaded executable file to install the driver software.   
 

(2-2) Confirmation of the driver software 
After displaying Start>Computer>Property(selected  
clicking the right mouse button)>System>Device manager, 
confirm that the driver software corresponding to the LAN 
card is displayed on the “Network adapters” item.(right 
figure) 
 

(2-3) Setting of the XP firewall 
When the operating system is Windows XP, set up a firewall  
of the host PC(which captures image) according to the  
following procedure after having completed “3.Installation of  
the iPORT software” on the next page. 

(Note) It is not required in the case of Windows7 and Vista. 
 

In the initial setting of Windows XP, the communication of specific network packets treated by the user program  
which was created using attached software (GEVPLayer or Coyote) may be blocked by the XP firewall. 
It is required to permit the communication of packets treated by these software by changing the XP firewall  
setting on ahead. 

①Display an options window of “Windows firewall in order of ”Start>Control Panel >Windows Firewall 
②Open the “Exceptions” tab after confirming that the check box of “Don’t allow exceptions” is not checked on step 

①, then click “Add Program” button.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

③Make the Exceptions setting by clicking the “OK” button after selecting GEVPLayer, Coyote and created user 
program each from the list of adding programs. 
→ Close the “Windows firewall” window by clicking “OK” button upon completion of the setting. 
(Note) It is not required in the case of VISTA. 
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3.Installation of iPORT software 
 

Here, it is explained on how to install the IP driver (eBUS driver) and SDK. 
(Note) The following is a Windows 7-based description. It differs slightly for the case of Windows XP. 
 

(3-1) Installation of eBUS SDK 
eBUS driver, GEVPLayer(used for searching cameras at initial stage and for IP address setting) and Driver 
Installation Tool etc. are installed when installing eBUS SDK.  

①Double-click “eBUS_SDK_2.0.1.1951.exe” in “SDK” folder in the attached CD-ROM. 
eBUS SDK-InstallShield Wizard runs.(see diagram below) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) In the case of Windows XP, a warning massage may appear as below in the middle of installation. In that 
case, interrupt to install clicking “OK”, and refer to the interpretation in (3-4) 
 
 
 
 
 
 
 
 
 
 
 
 
 
②Check the “I accept the terms in the license agreement” check box after confirming the contents of “License 

Agreement”, then click “Next”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Specify the folder of default setting unless there is some particular reason. 
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③The installation of eBUS SDK is completed when “InstallShield Wizard Completed” appears. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
(3-2) Installation of eBUS Driver 

eBUS driver is installed at the same time as installation of SDK in the case of CD-ROM(Ver.1.4 or earlier version), 
however, in the case of CD-ROM(Ver.2.0 or later version),eBUS driver should be installed separately from the 
installation of SDK, according to the following procedure. 
 
(Note) Do not install the eBUS Driver when connecting the camera using the development circumstances by 
third party (e.g. MIL by Matrox, Vision Pro by Cognex, LabView by Instruments, HALCON by MVTech etc.). 
The image signal may not normally be captured ,if the eBUS Driver is installed in this case. 
 

①� Starting of “eBUS Driver Installation Tool” 
Select the “Driver Installation Tool” in order of “All programs>Pleora Technologies Inc.>eBU SDK>Tools>Driver 
Installation Tool” and start it. 

 

 
 
② The window of “eBUS Driver Installation Tool” will appear. 

The list of LAN cards(or onboard LAN controller) currently installed in PC is displayed.  
 
Network Adapter MAC… MAC address of each LAN card (or Controller) 

 Description           … The information of each LAN card (or Controller) 
 Current Driver        … The Driver currently installed 
  Action               …  Next action to be executed  
 
Defalt status of “Current Driver” column is “Manufacturer Driver” when installing eBUS Driver for the first time. 
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③Selection of the Driver to be used 
 

eBUS Optimal Driver…  The optimal driver when using the intel PRO/1000  
series LAN card or the 825xx series LAN (onboard)  
controller chip. It is recommended to select this  
Driver under normal use. 

eBUS Universal Driver… This is selected when using the Network controller  
other than the intel PRO/1000 series LAN card or  
the 825xx series LAN (onboard) controller chip. 
It operates fast in synchronization with most of  
LAN controllers by various makers. 

Manufacturer Driver  … Brings back to LAN card’s original driver not using  
eBUS driver. GigE camera can not be connected in  
this situation. 

 
 

④Click the “Install” button at the bottom right of the “eBUS Driver Installation Tool” after selecting the driver. 
“Installing” and Progress indicator are displayed and installation of the driver gets started. 
If the “Windows security” window pop up on the way as the diagram below, place a check mark on the check  
box of ”Always trust software from “Pleora Technologies Inc.” then proceed with the installation”. 

 
  
 
 
 
 
 
 
 
 
 
 
 
(Note) It may take several minutes to install the driver. 
 

⑤When “Reboot Needed” is displayed, click “Yes”button. 
 
 
 
 
 
 
 
 
 
 

⑥Click “Close” button after confirming that the driver selected as the “Current driver” has already been installed. 
 
 
 
 
 
 
 
 
 
 
 

※ Skip to chapter 7 ”Start-up of GEVPlayer and Image capturing” when the development is conducted using only 
GenICam API.  
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(3-3) Installation of eBUS-Vision Package 
※ The following may be skipped if the development is conducted using only GenICam API. 
eBUS-Vision Package is installed. The demonstration display software “Coyote”, Code sample and Document etc. 
are installed by this operation. 
 
①Double-click “eBUS-Vision_Package_4.0.1.1951.exe” in “SDK” folder in the attached CD-ROM. 

eBUS-Vision Package - InstallShield Wizard runs.(see diagram below) 
 

 
 
②Check the “I accept the terms in the license agreement” check box after confirming the contents of “License 

Agreement”, then click “Next”. 
Specify the folder of default setting unless there is some particular reason. 

 

 
 
 
③Click the “Finish” button and exit it when “InstallShield Wizard Completed” appears. 
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(3-4) How to deal with the problem at installing iPORT software (in Window XP case) 
 

If the operating system is Windows XP, the following problems may occur in the middle of installing. 
In such case, take following measures to deal with them. 
 
[Case 1] The following error message is displayed and the installation is suspended. 
・puregev – InstallShield Wizard “ ! Microsoft .NET Framework Version 2.0 was not detected …” 
“Microsoft .NET Framework Version 2.0” or later version is needed for installation. 

 

 
 

[Countermeasure]  Install the “Microsoft .NET Framework Version 2.0” or later version. 
It is available from the web site below. 
http://www.microsoft.com/japan/msdn/netframework/downloads/ 

 
[Case 2] The following error message is displayed and the installation is suspended. 
・Pleora_Eb_App_DIT_32 - InstallShield Wizard “ ! Installation aborted …” 
The installation was suspended because there exist bugs in the Windows XP of current version.  
 

 
 

[Countermeasure] Execute the hot-fix in “Windows Update” function and reinstall it. 
                 Update to XP (SP3) if it does not make an improvement. 

XP(SP3) is available from the web site below. 
http://www.microsoft.com/japan/windows/products/windowsXP/sp3/ 
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4.Installation of software tool 
 
※It is not required to install “FCTool” and ”com0com” which are described below, because it is able to confirm and 
change the setting parameters via GenICam API in the case of using GEVPlayer that is the viewer software of 
“eBUS SDK” and the case of using the software developed in that development circumstances. 
   
The software for serial communication is needed to make an operational setting of FC-GE camera using Coyote that 
is the viewer software included in the attached “eBUS-Vision Package”. The attached (or downloaded from 
TAKENAKA’s website) FCTool and the Null-modem emulator software”com0com” that is the GPL license software 
(kind of free software) are used as the serial communication software for the initial setting. Refer to the document 
attached to each software about instructions and directions for use. 
 
(4-1) Installation of FCTool 

See “Installation Instruction of FC Series Camera Control Software FCTool” for details which is supplied with the 
software. As the installer function is omitted from FCTool (Ver.1.00), save the extracted file on the appropriate 
folder. 
 
※Uninstallation is completed by deleting all the saved files. 

 
(4-2) Installation of com0com (32bit/XP, Windows7) 

※Refer to section (4-3) for installation to 64bit/Windows7 PC.  
When controlling the FC-GE camera with the serial communication software 
(FCTool etc.) via the demonstration display software “Coyote”,  
the demonstration display software and the serial communication software run 
exchanging commands with each other’s serial port. Therefore, Null-modem cable 
should be prepared to connect between each other’s COM ports. (A) 
However, many PCs are not equipped with two COM ports in recent years, 
whence complex issues including necessity of preparing cable are raised. 
 
The Null-modem emulator software is the driver software to virtually realize these two COM ports and 
Null-modem cable on a computer software. (B) 
 
It is installed by executing “setup.exe”in the attached file (com0com-2.1.0.0-i386-chk.zip) 

 
①� Double-click “setup exe” and start the installation process. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
② Click “I Agree” button on the “Licence Agreement” screen to proceed. 
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③ During the progress of installation, the command prompt screen (black screen) appears and at the same time 
the following “Windows security” dialogue appears and displayed as “Windows can’t verify the publisher of this 
driver software”  
Select “→Install this driver software anyway” to proceed. 

 
(Note) It may take several minutes to install the driver. 
 
The command prompt screen is automatically closed as the installation of the software progresses. 
“Installation Complete” window is displayed when the installation is normally completed.  
 

 
 
Then, click “Next>” button to proceed on to the designation of the number of the next virtual COM port. 
 
④  “Completing the Null-modem emulator (com0com) Setup Wizard” screen is displayed following the foregoing 

“Installation Complete” screen 
 
Then, check the “Launch Setup Command Prompt” check box and click the “Finish”button. 
(Port number setting can be made later)  

 
 
 
 
 
 
 
 
 

[Explanation] 
Two names like CNCAO,CACBO are allocated to two ports as default, in case of “com0com”. 
It is explained how to change the name from CNCAO to COM5 and from CNCBO to COM6, in the following. 
These names should be COM1 to COM8 when using FCTool, other names than those can be used, though. 
It is not possible to allocate the same names on two ports and to allocate the port name which has been 
already allocated on PC.  
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⑤The command prompt screen is displayed.(see diagram below) 
 

 
Enter the command as follows.(underlined portion) 
command> change CNCA0 PortName=COM5 (Return) 

Then 
command> change CNCB0 PortName=COM6 (Return) 

In this way, the names of two ports(COM5,COM6 in this case) has been allocated.  
Click the close button on top right to exit the command prompt screen when the allocating process is completed. 
 
⑥ Start the Device manager of Windows. 

(Start>Computer>Property(selected clicking the right mouse button)>System>Device manager) 
 
Confirm that the items of com0com-Serial port emulators are displayed and that the designated COM port name 
(like COM5<->COM6) is displayed. 

 
 

※Here, two virtual ports have been defined. When performing the communication control of the camera using 
FCTool and Coyote, it will be able to mutually communicate by designating the FCTool port as COM5 and the 
Coyote port as COM6.(COM5 and COM6 may be designated in an opposite manner)  
 

⑦ Changing the port name 
When willing to change the port name later, call up the prompt screen by proceeding in order of “Start > All  
Programs > com0com > Setup Command Prompt” and enter a command. 

→Refer to the Readme.txt attached to each software about instructions and directions for use. 
 

(Example) After having changed the port name to “COM5” once, this is the case with the port name be changed to  
“COM4” next time..   

Call up the prompt screen by proceeding in order of “Start > All Programs > com0com > Setup Command Prompt” 
and enter a command as follows.(underlined portion) 
Command>change CNCAO PortName-COM4 (Return) 

 
⑧ Uninstallation 

It is executed by proceeding in order of “Start > All Programs > com0com > Uninstall” 
 
(4-3) Installation of com0com (Windows7/64bit version) 
 ※This program can run only on “Test mode” in case of Windows7(64bit version).  

It is installed by executing “setup.exe”in the attached file (com0com-2.2.1.0-x64-fre.zip) 
Refer to section (4-2) for details as the installation procedure is the same as that of 32bit version.   

 
The com0com installed in this way can run only on “Test mode” in case  
of Windows7(64bit version). 

 
Open the command prompt screen by the administrative right, then  
enter the following command.( All Programs > Accessories> Command Prompt(“logon as an administrator” by 
right-clicking the icon))   
 
bcdebit.exe/set TESTSIGNING ON (Return↓) 
 
Then the com0com(64bit version) runs by restarting the Windows  
 

(Note) Enter ” bcdebit.exe/set TESTSIGNING OFF” to cancel the Test mode by the same procedure as above. 
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5.Start-up of camera and image capturing 
 
(5-1) Camera connection 
※The setting examples below are described on the  

assumption that the camera is connected to the  
expanded LAN card that is inserted into the PCI slot of PC. 
 
Apply the power to PC after making an electrical  
connection between Camera, Power supply and LAN card  
with the dedicated cable for each. 

 
(5-2) IP address setting of iPORT engine with GEVPLayer 

Set the IP address of the iPORT engine in the camera 
according to the following procedure and confirm  
the connecting status between the camera and PC displaying  
the test pattern with iPORT engine. 
 

 
①�  Start up the “GEVPlayer” by proceeding in order of “Start > All Programs > PleoraTechnologies Inc >  

GEVPLayer” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

② Display “GEV Device Selection” dialog clicking “Select/Connect” button, then check “Show unreachable GigE 
Vision Device” at the lower left of this pane.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
※ Leave it as it stands for a while (up to about 20 seconds) waiting for the PC-connected camera to be displayed. 
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③ The name of the connected camera (e.g. “FC5200GE…”) is indicated with red circle as below, as IP address is 
not yet set at the first connection. The indication with red circle represents that the IP address is not properly 
set. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

④ Right-click on the area indicating a camera type (e.g. “FC5200GE…”) with red circle then left-click on “Set IP 
Address”. 

 
 
 
 
 
 
 

Right-click the line with red circle → Left-click “Set IP Address”  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

GigE Vision Device (camera) 
IP Address setting screen 
 

Select the IP Address that does 
not overlap among devices. 

Confirm that the red circle disappears. 
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⑤ Click “OK” button to close “GEV Device Selection” dialog. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

⑥ Click “Play” button (green triangle) of “GEVPlayer”.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

⑦ Click “Play” button (green triangle) of “GEVPlayer”.  
The image transmitted from the camera is displayed as the diagram below. 
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(5-3) Image capturing by Coyote 
Camera Images are captured using Coyote which is the demonstration display software attached to SDK. 
Connect the camera cable and the LAN cable in advance before executing following procedure. 
 

①�It starts up by proceeding in order of “Start > All Programs > Pleora Technologies Inc > eBUS Vision Package > 
Coyote” 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

② When clicking the “Detect” button, “IP Engine Selection” dialog is displayed and the MAC address and IP 
address of the connected camera are displayed as follows. 
Left-click on the “P Engine; MAC…” line to highlight it. Then click ”OK” button.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

③ “IP Engine Selection” dialog is hidden and IP address, MAC address, MAC address of NIC(LAN card) and 
others of the camera are displayed on a “Coyote” window. 
Click the lower left “Connect” button to start up the IP connection between the camera and PC. 
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④ The “Connect” button gets dimmed and the “Disconnect” button turns to deep color. 
At this point, IP connection starts up between camera and PC.  
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

⑤ Now, the camera and PC come into IP connected status.  
Check if the connection is normally made through the following steps. 
Select “IP Engine” >”Test network connectivity” in the “Connection” tab. 
It is confirmed that the connection is normally made if it is displayed as “The IP Engine is powered and 
connected to the Ethernet network” like lower right diagram. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

⑥ Confirmation of a live image display 
Open the “Acquisition” tab and click the “Start” button. Then the image outputting from the camera is 
displayed  
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(Note) It may take a few seconds for the image to be displayed. 
(Note) Menu display is set to ON and output bit depth is set to 8-bit as a factory default. 

When using Coyote, these settings can be changed using the serial communication command which is 
described in chapter 6 “Operational setting by serial communication command”. 

(Note) Live image may not be displayed, if the display capability of VGA card (or on-board graphic function of PC 
motherboard) is insufficient after setting the output bit depth for capturing to 10 or 12 bit. In this case, it may 
become possible to display it by changing the capturing bit depth(pixel depth) from 10 or 12-bit to 8-bit in the 
process of [Configuration window setting]. When the pixel depth is changed, the image output bit depth on the 
camera block side needs to be changed to corresponding bit depth.  

(Note) When zooming out the live display image, a noise pattern with pale vertical stripes may come up depending 
on a display magnification.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

※ Click the “X” button at the upper-right corner of the live display window to terminate the live display. 

[Explanation] Coyote live display screen manipulation 
● Right-click menu manipulation 
The menu is displayed as the right diagram indicates by clicking the right mouse button  
on the Coyote live display image. 
Zoom Fit …Displayed in a size to fit in a monitor display screen. 
Zoom 1:1 …Displayed with monitor screen corresponding one pixel to one pixel with  

camera image sensor. 
Zoom Out …Every time being selected, a display screen image is zoomed out. 
Zoom In  …Every time being selected, a display screen image is zoomed in. 
Zoom User…Display magnification is set to designated value. 
Recenter  …Selected to move the image center to the monitor display center again after  

having displaced the image center from the display center.  
Lock on center…Displayed with the image center being fixed to the monitor display center, 

 if “Lock on center” is checked.(checked as default) 
Resize window…When a display screen image is zoomed in/out, the screen image may be overlapped with the 

image of previous magnification. In this case, it is resolved by selecting “Resize window”. 
Backfroud …This is to designate the background color. 
Properties …The information of the frame rate or display magnification etc. of the current live image is displayed. 
 

● Mouse manipulation  
Mouse wheel …It can zoom in/out by rotating the wheel back and forth putting the mouse pointer over the display window. 
Drag operation …It can move the image display position by dragging the mouse pointer on the image with  

“Lock on center” unchecked. 
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CAMERA BLOCK⑦ Configuration of iPORT I/F (System definition) 
This equipment consists of Camera block part and  
GigE interface(iPORT I/F). 
 
・Parameter setting for Camera block part  
It is made with serial communication commands  
using the communication function of Coyote. 
 
Refer to the description of “6. Operation setting with serial communication commands” and “Serial 
communication control” in the separate “Camera instruction manual” 
 
・Setting for GigE interface (iPORT I/F)  
It is made with “Configuration” dialog in Coyote. 
 
“Configuration” dialog is displayed when clicking “Configure” button on the main window as indicated below. 
 
 
 
 
 
 

  

 
 
 
 
 
 
 
 
● Example of configuration (1)  Change in the image bit depth 
The image output bit depth is set to 8 bit as factory default both for monochrome and color equipment. 
It is required to change the output bit depth on camera head side using serial communication command and to 
change the configurations on iPORT I/F side together. 
 

Select the “Pixel” tab in “Configuration” dialog. Then select the image bit depth from the “Pixel depth” pull-down menu. 
Please refer to the “Instruction manual” for each camera, as selectable bit depth varies according to camera type. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) It is necessary to change the image output bit depth on camera head side to corresponding bit depth 

(8bit/10bit/12bit) before changing the image bit depth configuration by Coyote. 
→ Refer to “6.Operational setting by Serial communication command” for the detail. 

“Configuration” dialog 

[Pixel tab]  “Pixel depth” 
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● Example of configuration (2)  Setting of Request timeout 
It defines the maximum standby time during which the host PC is awaiting the image frame data sent from the 
camera. The default value in Coyote is “5000”ms.  
The image data which overran this timeout value are deemed as an invalid image, hence it becomes impossible to 
normally capture images. 
 
The default value “5000”ms is a sufficient time length when using the camera in the continuous shutter mode or no 
shutter mode, however when the camera is used in the asynchronous shutter mode and a trigger signal interval  
exceeds 5 seconds, normal image capturing may not be possible due to a timeout error. 
 
Therefore, change the setting value to sufficiently-large value when using the camera in the asynchronous shutter 
mode or in the long exposure mode of more than 5 seconds.  
Especially, when the camera is used in the asynchronous shutter mode and a trigger signal interval is indefinite, the 
timeout value(standby time) gets infinite by setting the timeout to “4294967295=0xffffffff” and the invalid data never 
arise even when the image data is not output from the camera block for a long time in the asynchronous shutter 
mode. In the long exposure mode of more than 5 seconds, specify the timeout value larger than that exposure time.       
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
● Example of configuration (3)  Setting of RGB Filter 
When connecting the Bayer RGB camera (FS5200GE etc.) and capturing images, it can set the level of Gain and  
Offset for each R,G,B to take a balance of R/G/B color(white balance). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) The pixel data are corrected by the following formula in accordance with “RGB Filter” setting values. 

Numerical value after correction=Numerical value before correction × Gain + Offset 

[IP Engine tab]  “Request timeout” 

[RGB Filter tab] 
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(Note) “RGB Filter” tab is not displayed with a title “Configuration-Basic” being displayed on a title bar of 
Configuration window. Make “Configuration-Advanced” be displayed on a title bar by checking the “Show 
advanced configuration pages” check box at the bottom left of the window. 

 
 
 
 
 
● Example of configuration (4)  Use of 3×3 Bayer interpolation 
It can select 3×3 pixels Bayer interpolation as substitute for 2×2 pixels Bayer interpolation of initial setting, when 
capturing images by Coyote connecting Bayer RGB camera(FS5200GE etc.). It can inhibit the generation of aliasing 
or false color around a transverse line or an object edge by selecting this interpolation method. However the 
processing speed of host PC is reduced, as it takes time for interpolation processing.    

 
 
 
 
 
 
 
 
 
 
 
 
 
 
※ Click the “OK” button at the bottom of “Configure” window to close the window after completion of  

configuration. 
 

⑧ Saving the configuration data into config.file. 
It can save the configuration data set at ⑦ as a config file to use it after next start-up. 
Click File > Save As…. to proceed (diagram below), then save the configuration data to the destination 
designating the appropriate folder name and file name 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※The file name extension is “.xml”.  When “Save” button is clicked without an extension, the  

extension ”.xml” is automatically attached    

[Pixel tab]  “Use 33 Bayer Interpolation” 
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(5-4) Start-up of Coyote using a configuration file [case1] 
If the Coyote has normally started on the procedure described in (5-1)~(5-3), it becomes easier to start it by  
opening the configuration file from the Coyote since second start-up. 
 

①�It starts up by proceeding in order of Start>All programs>Pleora Technorogies Inc>eBUS Vision  
Package>Coyote 

 
 
 
 
 
 
 
 
 
 
 
 
 

② Click the left mouse button after proceeding in order of File>Open  
 
 
 
 
 
 
 
 
 
 
 
 
 

③ Select the configuration file (xml file) saved and click the “Open” button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

④ “Connect” button automatically gets dimmed, and the next “Disconnect” button turns deep color. 
The camera and PC are IP connected in this situation. 
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(Note) In the case that the connection is not yet completed immediately following the starting of the camera and the 
error message “Error=CY_RESULT_TIMEOUT(30)” is indicated, open the “IP Engine Selection” window from the 
“DETECT” tab, then click the “Connect” button after selecting the connected camera. Then proceed on to ⑤, 
after completion of the connection.   

 
⑤ Open the Acquisition tab from the “Coyote” window and click the “Start” button. 

Confirm that the images being taked by another camera is displayed live on the PC monitor. 
 
※Subsequent operation procedure is the same as that of (5-3)⑥ or later. It is not needed to resave the 
configuration file if “Configure” data are not changed. If the configure data are changed(e.g. changed the image bit 
depth from 10bit to 8bit ), it comes to be able to starting from the requisite setting status(cf.10bit/8bit) selecting the 
file to open at the time of startup by saving the configure data under an alias via “Save As…” in the Configuration file 
 
(5-5) Start-up of Coyote using a configuration file [case 2] 

If the Coyote is started connecting the camera(same model, different serial.No.) other than that with which the  
configuration file was made, go through the following steps. 
These steps are applied also to the same camera having being connected the last time with changed IP  
address.    
 

①�It starts up by proceeding in order of Start>All programs>Pleora Technorogies Inc>eBUS Vision 
Package>Coyote. 

②�Click the left mouse button after proceeding in order of File>Open. 
③�Select the configuration file (xml file) saved and click the “Open” button. 

※Same as (5-4) up to this point,  
④�An error message window of “Error = CY_RESULT_NETWORK_ERROR(19)” or “Error = CY_RESULT_ 

TIMEOUT(30)” is displayed as follows. 
Click the “OK” button to close this window. 
 
 
 
 
 
 
 
 
 
 
 
(Note) This is the error arising from the fact that the MAC address or IP address saved in the configuration 
file (xml file) is different from that of the currently connected camera. 

 
⑤�Click the “Detect” button on the Connection tab.  
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⑥�Newly connected camera is detected and the corresponding MAC address and IP address is displayed. 

Select this to highlight and click the “OK”button. 
 

 
 
 
 
 
 
 
 
 
 
 

⑦�Click the “Connect” button after confirming that the new MAC address and IP address are displayed on the 
“Connection” (tab) screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 

⑧�Open the Acquisition (tab) screen in the “Coyote” window and click the “Start” button. 
Confirm that the images being taked by another camera is displayed live on the PC monitor. 

※The procedure from this point is the same as that of (5-3)⑥ or later. 
 

⑨�Save the configuration data into the configuration file. 
It can be saved as the configuration file of the MAC address and IP address corresponding to newly 
connected camera.  
Click File > Save As…. to proceed, then save the configuration data to the destination designating the 
appropriate folder name and file name(another name from previous file). 
 
※It can easily start Coyote by opening the newly created definition file(xml file) at second start-up or later. 
→ Refer to (5-4) 

 
(5-6) Other functions of Coyote 

Coyote has various useful functions,i.e.,Image saving function and Image data diagnostic function etc. in  
addition to Live image display function.  
For more information on operating procedure of Coyote, please refer to Coyote by proceeding in order of  
Start>All programs>Pleora Technologies Inc>eBUS Vision Package>Documentation.  

 
 
 
 
 
 
 
 
 
 
 
 
※ The software(Adobe Systems Inc./PDF Reader etc.) that can read documents in PDF format is needed to  

browse documents. 
※ Attached SDK includes the source code of Coyote. 
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6.Operatinal setting by serial communication command 
 
※When developing the software on the development environment (eBUS SDK) using GenICam API, the setting by  

serial communication command is not needed.  
 
The camera of this series can change the operational setting parameters using serial communication software. 
Any communication software is usable if it complies with the communication protocol that is described in “Serial  
communication control” in the separate instruction manual of the video camera.  
The description below focuses on how to configure the operational settings using the evaluation communication  
software for FC camera i.e. “FCTool” which is provided free by TAKENAKA   

 
(6-1) Preparation of serial communication port 

As explained in “4.Installation of software tool”, it is required to prepare two physical ports (“COM1”and”COM2”)  
and a null cable (virtual cable that establishes a connection between TXD and RXD ), or to install a null modem  
emulator software(attached com0com etc.) into PC being used, in advance. It is assumed in the following 
description that the two ports COM5 and COM6 are made available using a null modem emulator software. 
→ Refer to “4. Installation of software tool” 

 
(6-2) Installation of FCTool 

The description below Is based on the premise that FCTool (Ver.1.00 or later version) has been installed in the 
“c:¥Program Files¥FCTool” folder.  
→Refer to “Installation Instruction of FC Series Camera Control Software FCTool” enclosed in FCTool. 

 
(6-3) Starting of serial communication 

① Start the Coyote in accordance with the explanation in section 5. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

②  Display “Serial Port Configuration” dialog box by proceeding in order of IP Engine>Serial COM Port 
Link… ,starting from the menu bar on Coyote. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) “Serial Port Configuration” can not be displayed unless the camera is normally connected(e.g. “Connect” is 

dimmed in the window of above figure). 
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③ Select the port to be used for the communication (COM6 here) from the “Port” pull-down menu in the “Serial 
Port Configuration” dialog box. Then click the “OK” button.. 

 
 
 
 
 
 
 
 
 
 
 
 
※ Then, Coyote is ready to start the serial communication using “COM6”port. 
(Note) When using the serial command by Coyote, it is required to execute steps ②~③ every time on 

start-up of Coyote. 
 

④ Start FCTool. (Open the folder where FCTool.exe is saved, then double-click on FCTool.exe) 
“Please configure port settings” dialog is displayed at the first start-up. 
Click “OK” here to display “FCTool (COM port settings)”, then select “COM5” from the “Port” pull-down 
menu 
 
 
 
 
 
 
 
 
 

(Note) It should be noted that “COM5” different from the port No. of Coyote is selected. 
   The “COM5” port of FCTool and the “COM6” port of Coyote come to be connected by a virtual null  

modem cable, through the above procedure.   
(Note) it is not required to reconfigure the port number(PORT) and the baud rate(BPS) until they will be  

changed, as the contents of “FCTool (COM port settings)”are stored in case of FCTool.  
         

⑤ Then, the FCTool starts by clicking “OK” on “FCTool (COM port settings)” 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※ If the “No camera found” error is displayed” on start-up of FCTool, recheck if the port number setting on  

Coyote side (COM6 in this case) and that on FCTool side(COM5 in this case) are correct.  
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⑥ Confirm the version report of the camera to see if the FCTool is normally communicating with the camera. 
Enter “RV” in the upper entry field on “FCTool (Direct command)”window, then click “SEND” button or press 
the return key.  

 
 
 
 
 
 
 
 
※The camera type and the version code are displayed as “RTakenaka SYS…” on the lower field of “FCTool  

(Direct command)” window if the communication situation is normal. 
 
 
 
 
 
※When the communication situation is not normal, check if there is an error in the name of virtual port  

number(“COM5”,”COM6” etc.) or if the null modem emulator software has been normally installed. 
It is able to confirm from the device manager of windows whether the null modem emulator software has  
been normally installed. 
→Refer to “4.Installation of software tool” for details. 
 

※As the steps ②~③(Serial communication port setting of Coyote) can not be stored in the configuration file 
(xml file), it is required to execute these steps every time on start-up of Coyote. 

 
(6-4) Example of the setting step by serial communication 

The following are the examples to actually change the setting parameters e.g. the camera gain setting by FCTool  
or the output bit depth switching.  

・MGC gain setting 
It can be changed operating the MGC slide bar in FCTool. 

 
 
 
 
 
 
 
 
 
 

It can also be set directly inputting the “G” command of the camera by using “FCTool (Direct command)” 
   If it is required to set the setting value to “90”(=H’5A), input “G5A….” in the entry field of the direct command and  

send it out 
 

 
 
 
 

・Exposure time(Shutter speed) setting 
There are several ways to set the exposure time. The way made by ”external preset value setting” is explained  
here. →Refer to the Video Camera Instruction Manual and the FCTool instruction manual (included in the  
FCTool distribution file) of separate volume,for the detail.  
 
The setting is made operating on “exposure time setting block in the compact display area” of FCTool. 
The diagram below shows the example where the shutter preset value is set to “7” 

 
                                    
 
 
(Note) The shutter value(VALUE) corresponding to the preset value varies according to the type of camera or 

settings of shutter table.   

Check the EXT check box and select the 
shutter switch position by +/- button below 
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  ・ON/OFF setting of OSD menu display 
Click the “MENU OFF” or ”MENU ON” button on FCTool. 
 
 
 
 
 
 
 
 
 

・Setting of image output bit depth 
Image output bit depth can be set by changing the setting of the configuration register(CR) of the camera. 
Rewrite the configuration flag as follows, when making this setting using FCTool. 
Display the CR flag edit screen by proceeding in order of Tools>Edit Flags>CR Flags> starting from menu bar  
on FCTool, as the diagram below.  
For example, in the case of FC5200GE, output bit depth is determined by the contents of CR(4) and CR(3), 
i.g. 10 bit depth at CR(4)=0, CR(3)=0, 8 bit depth at CR(4)=0, CR(3)=1, 12 bit depth at CR(4)=1, CR(3)=0.  
 
The following is the example of (CR) flag setting when setting to 8 bit depth, i.e. CR(4)=0,CR(3)=1. 
Check the 3rd bit and click the “WRITE” button., 
   
 
 
 
(Note) Saving to the internal nonvolatile ROM is not executed by the above operation alone. The step of 

“Saving configuration items” is needed after this so that the settings continue to be stored even after 
power-OFF.   

 
 
 
 
 
 
 
 
 
 
(Note)If the images are captured under the condition that the bit depth setting does not accord with the “Pixel 

depth” value set at iPORT configure (see (5-3)), abnormal image(like lower left diagram) is displayed. 
(Sometimes, images may not even be displayed.) 
Be sure to change the configure data (Pixel depth) on iPORT side, when changing the output image bit 
depth of the camera by FCTool.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example of screen image  
with bit depth setting error 

Screen image after bit depth setting error 
is corrected 
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・Saving configuration items  
The settings will be lost concurrently with power-off of the camera, unless the saving step (saving to the  
internal nonvolatile ROM) is executed.  
Means for saving settings differ due to the fact that the configuration item is the “Program page item”  
or the ”Configuration item”. Refer to the video camera instruction manual of separate volume for information  
about which the setting item corresponds to. 
 

[Saving of Program page item]   
Regarding the program page items such as MGC setting value or the Continuous(NRML)/Asynchronous  
(ASYNC) shutter setting, select the program page to be saved (A to F) from the drop-down list on “SAVE”  
button side making the FCTool window enlarge to “FULL”screen, then click the “SAVE”button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※In order to have the direct command way working the same way as above, Input “WA”(saving to page A)  

to “WF”(saving to page F), then send the command.(upper right diagram) 
 

[Saving of Configuration item]   
Configuration items which is set by the configuration register(CR) such as ON/OFF setting of OSD menu or  
switching of image data output bit depth and other Configuration items (ID data and VSUB setting etc.) are  
saved by directly inputting the command corresponding to each set item. 

(e.g.) Set value of VSUB data→It can be saved by sending “SVSUB”command from the direct command input field. 
 
However, the contents of configuration flag(CR) and ID(ID information of the camera set by user) can also  
be saved from Tools>Save>Configuration Flags or CAM ID on the menu bar of FCTool. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

“WA” in the case of direct command input 

[Explanation] Setting by the direct command and the dedicated command button 
All operational settings of the camera can be done sending the defined character string(ASCII code) 
inserted between “STX”(=H’02) and ”ETX”(=H’03). Therefore, all defined control can be made by sending 
the prescribed character string from the direct command window.  
FCTool allows user to easily operate frequently used commands, e.g. MGC set value can be changed using 
slide bar, defined string of characters are automatically sent to change the operational mode with just 
one-click like “MENU ON(OFF)” button for easy operation.     
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7.Start-up of GEVPlayer and image capturing 
 
The image display method using the image display software GEVPlayer included in the attached SDK 

“eBUS-PureGEV Package” is described here. 
 

(7-1) The difference between GEVPlayer and Coyote 
The GEVPlayer is a image display software complying with GenICam API. It can change each configuration  
parameter(GenICam feature) directly accessing to the configuration register inside the camera without the  
external serial communication software. 

 
In case of a software development using Coyote-containing SDK “eBUS-Vision Package” and a serial  
communication software, it is required to design the software specifically for the camera after understanding the  
meaning of the serial communication command inherent in the camera. On the other hand, in case of a software  
development using GEVPlayer-containing SDK ”eBUS SDK”, the developed software can be applied to the other  
camera models, other maker’s products and interface type cameras.  

 
 
 
 
 
 
 
 

(7-2) Starting and terminating GEVPlayer  
①� Start up the “GEVPLayer” by proceeding in order of “Start > All Programs > PleoraTechnologies Inc > eBUS  

SDK > GEVPLayer” 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

② Proceed on to “Select/Connect” button→”GEV Device Selection” dialog, then select the currently connected 
camera to click the “OK” button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) In the case that the IP address is not yet set up at a first connection. 
→Refer to (5-2) “IP address setting of iPORT engine with GEVPLayer”. 
(Note) It may take 20 to 30 seconds until the camera is detected from when “Select/Connect”button is clicked. 
 
 

[Terminology] GenICam 
It is a standard established by EMVA (European Machine Vision Association). 
It was established for the purpose of controlling cameras of different interface type (IEEE1394,CameraLink,GigE 
Vision etc.) with common API. 
It has the advantage for the software developer that it allows the cross-cutting software development regardless 
of interface type. 
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③ Start displaying by clicking “Play” button (green triangle) on “GEVPlayer”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

④ Stop displaying by clicking “Stop” button. Save the setting changed on “GEVPlayer” for next start-up, if 
needed. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※It facilitates starting at next start-up, as it start up reflecting the settings by opening this configuration  

file(.pvcfg file). 
 

⑤  Disconnect from the Ethernet line by clicking the “Disconnect” button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
(Note) Turn off the power to the camera after disconnecting with “Disconnect” button. The software may hang 

up if the camera is turned off in first. 
If the software hangs up by this reason, force-quit the GEVPlayer on PC side starting a task manager of  
Windows with a key operation [Ctrl+Alt+Delete]. 
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(7-3) GenICam feature (parameter) setting  
Each feature specified by the GenICam standard is set or the confirmation of that setting is made in the “Control  
dialog” described in the next section. 
 
The communication function of GEVPlayer (Function to read out/write into the configuration XML file of the  
camera) allows each feature(parameter) changed by GEVPlayer to be automatically transmitted to the camera  
head part and applied as needed without the external communication software as required in Coyote. . 
  
The naming and the function of GenICam feature is in conformity with the standard (Standard Features Naming  
Convention Version1.1) established by EMVA (European Machine Vision Association). 

 
(7-4) Control dialog  

“Parameters and Controls” is arranged on the bottom-left corner of the GEVPlayer main screen including the  
following three dialogs. 
 
“Communication Control”… It configures the settings on the transport layer of network. 

※It can display and configure in a condition that the camera is not connected, as it is  
the setting on GEVPlayer side.   

 
“GEV Device Control”   … It configures the parameter settings of IP engine inside the camera(iPORT) and  

the camera block. 
※It can display and configure after the connection with the camera is completed. 

 
“Image Stream Control” … It performs the stream (image data transmission) control between camera and  

PC and the statistical display(data transmission status display). 
※It can display and configure after the connection with the camera is completed. 
 

(7-5) Display style of Control dialog  
‧Visibility … It configures the Visibility grade for displaying. 
            Visibility grade for parameter display is determined according  

to how frequently the settings are changed. 
The Visibility has the following three grades. 
Number of display items increases as it varies “Beginner” 
→”Expert”→”GURU”, and all items are displayed in ”GURU”.  
 
The selective display gets easier by setting the lower Visibility  
grade like “Beginner”, when it is required not to display the  
infrequently-operated parameters.  
 

Beginner…Only the basic setting items which is frequently changed are displayed. 
 
Expert  …This is the semi-advanced setting. Even the items of which frequency of use is not so high 

are displayed. 
 
GURU  …This is the advanced setting. All items are displayed. 

  
‧Dimmed/Deep color display …The items of which the setting can not be changed like the read-only feature  

or the current status are dimmed and the items of which the setting can be  
changed are displayed in deep color. 

             
‧Types of setting items … There are various types of setting items including the one specified by the numeric 

value, the one selected from listed candidates, the one specified by entering 
command, and the one specified by entering character string etc..  
The setting of numeric value may has the upper/lower limit or specified incremental 
unit (incremented by one, two etc.).   
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(7-6) Example to change settings  
Various examples to change the settings using “GEV Device Control” of the Control diagram are described  
here.  
 
(Example 1) ON/OFF setting of OSD menu. 
OSD menu display is set to ON as a factory default in FC-GE series  
camera. The following shows how to switch the menu display to OFF 
 

・Select TakexCameraControls>OSDMenu>FCMenu to proceed. 
→ Select “OFF”(nondisplay) to press the return key. 
 

(Note) When the selected item is displayed in deep color during image  
screaming, it can essentially change the parameter values and  
reflect it to the camera while displaying images. However the image  
streaming may break up and the display action gets unstable  
depending on the performance of the PC used. 
In this situation, change the setting after stopping to display by  
clicking “STOP” button (red button). 
 

(Note) The changed setting of ON/OFF state of OSD menu is lost when the camera turns off, if this goes on. 
     If it is needed to enable the settings at next power-on of the camera, change the Visibility setting on top of this  

dialog window to Expert (or GURU) and click TakexCameraControls >SaveAndLoad>FcSaveCFG in this  
order. It is also possible to execute saving in accordance with “(Example 7) Saving settings” to be hereinafter  
described. 

 
(Example 2) MGC gain setting 
This is the example of how to change the MGC gain settings. 

 
・Select AnalogControl>GainRaw to enter the numerical number. 

The range of number is 0 to 255 in FC-GE series camera. 
It can increase/decrease by an increment of 1 or 2 by directly entering  
the numerical number or by clicking the up-down arrows on the right side  
of the entry field. 
 
The setting value is reflected to the camera by pressing the return key  
after changing the numeric value or by selecting other item. 
 

(Note) The changed setting of MGC gain is lost when the camera turns off,  
if this goes on. If it is needed to enable the settings at next power-on  
of the camera, select “PageA” starting from TakexCameraControls >SaveAndLoad>FcPageSelector, 
then click TakexCameraControls >SaveAndLoad>FcSavePage in this order. 
 
※The setting values saved in PageA are read out at the time of start-up and are applied to the operational  

setting parameter. 
 
It is also possible to execute saving in accordance with “(Example 7) Saving settings” to be hereinafter  
described. 
 

(Example 3) Exposure time setting-Continuous shutter-Direct designation of shutter exposure time 
This is the example of how to directly designate the shutter exposure time (cf.1000) in continuous shutter mode. 
Set a series of parameters as follows.  

① Select AcquisitionAndTriggerCntrols>ExposureMode, then, set to “Timed”. 
② Select AcquisitionAndTriggerCntrols>PresetShutter, then, set to “Exposure time”. 
③ Select AcquisitionAndTriggerCntrols>ExposureTimeRaw , then, press the return key entering “1000”. 

 
(Example 4) Exposure time setting-Asynchronous shutter-Designation of Preset value 
This is the example of how to designate the shutter exposure time to Preset 5 in asynchronous shutter mode. 
Set a series of parameters as follows. 

① Select AcquisitionAndTriggerCntrols>ExposureMode, then, set to “TriggerControlled”. 
② Select AcquisitionAndTriggerCntrols>PresetShutter, then, press the return key selecting “Preset 5”. 
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(Example 5) Exposure time setting-Continuous shutter-Designation of absolute time(unit:ms) 
This is the example of how to designate the shutter exposure time in μs in continuous shutter mode. 
(e.g.40000μs =40ms) 
Set a series of parameters as follows.  

① Select AcquisitionAndTriggerCntrols>ExposureMode, then, set to “Timed”. 
② Select AcquisitionAndTriggerCntrols>PresetShutter, then, set to “ExposureTime”. 
③ Select AcquisitionAndTriggerCntrols>ExposureTimeAbs, then,  

press the return key entering “40000”. 
 

(Note) The right figure shows an example when setting the numeric value  
”40000” in FC5200GE. Actually settable value “39999.3”μs is reflected  
against the input value “40000”. This is because the shutter exposure  
time is set in H unit(Horizontal synchronous time) at the camera side.  
 

→It is found that the value of “ExposureTimeRaw” is “814” in response 
to the value “40000”μs. That is,”814” corresponding to the H number  
closest to the set value “40000” is set into the camera.  
 

(Example 6) Setting of image output bit depth 
This is the example of how to switch the image output bit depth from 8 bit  
(default) to 10 bit. 

 
・Select “Mono10”(“Bayer RG10” in case of color) starting from  

ImageSizeControl>PixelFormat to press the return key. 
 
 
 
 
 
 
 

(Example 7) Saving settings 
This is the example of how to save the parameter settings so that the set contents are reflected at next  
start-up.  
① Select “UserSet1 ” starting from UserSets>UserSetSelector 
② Click UserSets>UserSetSave. 
③ Select “UserSet1” starting from UserSets>UserSetDefaultSelector 

 to press the return key. 
 
※Then, the set contents are saved onto XML file in the camera, and they are applied at next start-up.  

 
(Example 8) Restoring to default settings(Reloading of default settings) 

This is the example of how to restore the various parameter settings to default. 
① Select “UserSet1 ” starting from UserSets>UserSetDefaultSelector to press the return key. 
② Disconnect from the Ethernet line by clicking the “Disconnect” button. 
 

※Then, the camera will start in default state at next start-up. 
→ After restarting, save the settings to “UserSet1”. After that, restore “UserSetDefaultSelector” setting to  

“UserSet1” 
(Note) The startup settings are always in default configuration, as long as “UserSetDefaultSelector” setting is “Default”. 

 
 

(7-7) Other setting parameters  
Refer to the “Camera Instruction manual” attached to the camera for the details about other setting  
parameters (Features). 
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(7-8) Image Filtering function of GEVPlayer  
● White balance 

It is possible to adjust the white balance on the captured image of BayerRGB output type camera (FS5200GE  
etc.)  Select Tools>Image Filtering from the main window and display the “Image Filtering” panel. 
→ It is possible to take a white balance by clicking the “White Balance” button with a camera taking a image of  

a white paper etc..  Also, it can manually take a balance by changing the R/G/B ratio and Offset values with  
a slider. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Use of 3×3 Bayer Interpolation 
It can select 3×3 pixels Bayer interpolation as substitute for 2×2 pixels Bayer interpolation of initial setting, 
when capturing the images by Coyote connecting Bayer RGB camera(FS5200GE etc.). It can inhibit the 
generation of aliasing or false color around a transverse line or an object edge by selecting this interpolation 
method. However the processing speed of host PC is reduced, as it takes time for interpolation processing. 
 
 
 
 
 
 
 
 
 
 
Select “3×3 Interpolation” from “Bayer Interpolation” on the “Image Filtering” panel. 
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8.Attached SDK and document 
 
The “eBUS SDK”(note↓) and ”eBUS-Vision Package” are attached to the product as SDK. 
The “eBUS SDK” provides the development environment using GenICam API and the “eBUS-Vision Package”  
provides the development environment not using GenICam API.  
 
(Note) “eBUS SDK” was called “eBUS-PureGEV Package” in the existing versions (CD-ROM Ver.1.4 or  

older) and it is simply called “eBUS SDK” in the current version (CD-ROM Ver.2.0 or later). 
However as it is officially called “eBUS-PureGEV Package”, it may be described using this naming.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

(8-1) Browsing eBUS SDK related document files 
It is possible to browse the document files according to the following procedure. 
<”Getting started”(Initial procedure of development) and the Instruction for API class library> 
The document (in chm format) opens by clicking “Start > All Programs > Pleora Technologies Inc>eBUS SDK 
>API Documentation, in this order. 
It is possible to print out selecting the necessary part. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

[Important] Regarding selection of SDK at the time of development of application software 
 
This equipment adopts the Pleora (Canada)’s iPORT as IP engine. 
“eBUS-SDK“(GenCam API-compliant development environment) and “eBUS-Vision Package”(non-GenICam 
API-compliant) are available as SDK in iPORT. 
 
Although “eBUS-Vision Package” including demonstration display software “Coyote” has been used for many 
years as an iPORT development environment, Pleora strongly recommends to use “eBUS-SDK“(GenICam 
API-compliant development environment), as a trend shifting to GenICam API-compliant cameras becomes 
more common among third-party image processing software makers and many GigE camera makers.  
 
Except for particular reasons that iPORT interface or application software has been developed for years on 
the platform of Pleora’s “eBUS-Vision Package”, we recommend to develop the new application software 
using “eBUS-SDK“ that is the GenICam API-compliant development environment. 
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(8-2) The usage of code sample using eBUS SDK 
The code sample folder opens by clicking “Start > All Programs > Pleora Technologies Inc>eBUS SDK 
>Code Samples, in this order. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※Refer to “ReadMe.txt” in each folder for more information about each Code sample. 
 

(8-3) Browsing eBUS Vision Package related document files 
It is possible to browse the document files according to the following procedure. 
The document file opens by clicking “Start > All Programs > Pleora Technologies Inc>eBUS-Vision Package 
>Documentation, in this order. 
 

 
 
 
 
 
 
 
 
 
 
 
The browser is displayed as shown in the figure of next page. 
 
It is in the directory below as a default installation. 
C:¥Program Files¥Pleora Technologies Inc¥eBUS SDK¥Samples¥...... 
 

※Refer to “ReadMe.txt” in each folder for more information about each sample program. 
(Note) The sample codes of SDK are made on the “Microsoft Visual Studio 2005” as a standard development  

environment. 
(Note) All copyrights of SDK are held by Pleora Technologies Inc. CANADA. 
(Note) Use the sample programs upon agreement with the contents of License Agreement presented when the SDK 

is installed. 
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Next, select the necessary items and display them. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
※The software that can read the documents in PDF format (Adobe Systems Inc./PDF Reader etc.) is needed  

to browse the included documents. 
 

(8-4) Usage of eBUS Vision Package code sample 
It is possible to browse the c/c++ sample code samples by proceeding in order of Start>All Programs>Pleora  
Technologies Inc>eBUS-PureGEV Package>Code Samples. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The contents of Sample folder are displayed as the above diagram indicates. 
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 It is in the directory below as a default installation. 
C:¥Program Files¥Pleora Technologies Inc¥eBUS-Vision Package¥Samples¥...... 
 

※Refer to “ReadMe.txt” in each folder for more information about each sample program. 
(Note) The sample codes of SDK are made on the “Microsoft Visual Studio 2005” as a standard development  

environment. 
(Note) All copyrights of SDK are held by Pleora Technologies Inc. CANADA. 
(Note) Use the sample programs upon agreement with the contents of License Agreement presented when the SDK 

is installed. 
 

(8-5) Update of SDK 
We can accommodate a user’s needs of SDK update. However, please note that the user is responsible for  
the cost involved in sending the update software (processing fee, shipping cost etc.).   
 

-Finis-    
 
 


